Jump to content
Strain Hunters Forum
Guest Guest guest user
Existing user? Sign In  

Sign In



Or sign in with one of these services

Sign Up
Search In
  • More options...
Find results that contain...
Find results in...
manos

2 problems,what happened?

Recommended Posts

shades_smile.gifPoor pics, it could be 1 off a few things.........

shades_smile.gifFrom pic it looks like your camera is fogging up so that could be high humidity. Humidity should be no higher than 55% last few weeks off flower.

shades_smile.gifcould also just be the strain using the last of the nitrigon in the larger leafs. Some strains are famous for it. G13 for example yellows of last 2 weeks of flower.

shades_smile.gifOr as you said over fert. In which case just flush till water coming from bottom of pot is Ec .2 or there abouts. If you are only 10 days from finish just feed fresh water till harvest. And me personley I would take the larger yellow stuff off now. All it is doing is shading the buds underneath.....................Happy growing

Link to post
Share on other sites
Guest superbluehaze

Flush my friend;

and flush again;

the plants have been feed toxic levels of nutrients;

take all the damaged leaves off the plant;

and let them dry out.

happy harvest,

john

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...